Commit 45131402 authored by Mathias Ettinger's avatar Mathias Ettinger

Package the 6.0.0 version

parent 63cacac0
#!/bin/bash
# Process this file with autoconf to produce a configure script.
AC_INIT(opensand-conf, 5.2.0, [http://opensand.org])
AC_INIT(opensand-conf, 6.0.0, [http://opensand.org])
AC_CONFIG_SRCDIR([src])
AM_CONFIG_HEADER([config.h])
AC_CONFIG_MACRO_DIR([m4])
......
#!/bin/bash
# Process this file with autoconf to produce a configure script.
AC_INIT(opensand-core, 5.2.0, [http://opensand.org])
AC_INIT(opensand-core, 6.0.0, [http://opensand.org])
AC_CONFIG_SRCDIR([src])
AM_CONFIG_HEADER([config.h])
AM_INIT_AUTOMAKE
......@@ -47,17 +47,17 @@ CXXFLAGS="$CXXFLAGS -std=c++11"
# check for opensand-conf library
PKG_CHECK_MODULES([OPENSAND_CONF], [opensand_conf = 5.2.0])
PKG_CHECK_MODULES([OPENSAND_CONF], [opensand_conf = 6.0.0])
LIBS="$OPENSAND_CONF_LIBS $LIBS"
AC_SUBST(AM_CPPFLAGS, "$OPENSAND_CONF_CFLAGS $AM_CPPFLAGS")
# check for opensand-output library
PKG_CHECK_MODULES([OPENSAND_OUTPUT], [opensand_output = 5.2.0])
PKG_CHECK_MODULES([OPENSAND_OUTPUT], [opensand_output = 6.0.0])
LIBS="$OPENSAND_OUTPUT_LIBS $LIBS"
AC_SUBST(AM_CPPFLAGS, "$OPENSAND_OUTPUT_CFLAGS $AM_CPPFLAGS")
# check for opensand-rt library
PKG_CHECK_MODULES([OPENSAND_RT], [opensand_rt = 5.2.0])
PKG_CHECK_MODULES([OPENSAND_RT], [opensand_rt = 6.0.0])
LIBS="$OPENSAND_RT_LIBS $LIBS"
AC_SUBST(AM_CPPFLAGS, "$OPENSAND_RT_CFLAGS $AM_CPPFLAGS")
......
......@@ -8,7 +8,7 @@ from distutils.core import setup
setup(
name='opensand-network',
version='5.2.0',
version='6.0.0',
author='Viveris Technologies',
author_email='aurelien.delrieu@viveris.fr',
url="http://opensand.org",
......
#!/bin/bash
# Process this file with autoconf to produce a configure script.
AC_INIT(opensand-output, 5.2.0, [http://opensand.org])
AC_INIT(opensand-output, 6.0.0, [http://opensand.org])
AC_CONFIG_SRCDIR([src])
AM_CONFIG_HEADER([config.h])
AM_INIT_AUTOMAKE
......
......@@ -48,6 +48,8 @@ make_core()
make_services()
{
echo "Building OpenSAND services for $TARGET_DIST"
# Package and install opensand-deploy
$THIS_DIR/$TARGET_DIST/build-pkg $USEROPTS -s $SRC_DIR -d $DST_DIR $INSTALL_DEP opensand-deploy
# Package and install opensand-collector
$THIS_DIR/$TARGET_DIST/build-pkg $USEROPTS -s $SRC_DIR -d $DST_DIR $INSTALL_DEP opensand-collector
# Package and install opensand-meta
......@@ -156,8 +158,8 @@ case $MODULE in
"all")
make_libs
make_core
make_services
make_encap
make_services
;;
"libs")
make_libs
......
opensand-collector (6.0.0) xenial; urgency=low
* Release 6.0.0
-- mettinger <mathias.ettinger@viveris.fr> Tue, 9 Mar 2021 15:00:00 +0200
opensand-collector (5.2.0) xenial; urgency=low
* Release 5.2.0
......
opensand-collector (6.0.0) xenial; urgency=low
* Release 6.0.0
-- mettinger <mathias.ettinger@viveris.fr> Tue, 9 Mar 2021 15:00:00 +0200
opensand-conf (5.2.0) xenial; urgency=low
* Init
......
opensand-collector (6.0.0) xenial; urgency=low
* Release 6.0.0
-- mettinger <mathias.ettinger@viveris.fr> Tue, 9 Mar 2021 15:00:00 +0200
opensand-core (5.2.0) xenial; urgency=low
* Release 5.2.0
......
opensand-collector (6.0.0) xenial; urgency=low
* Release 6.0.0
-- mettinger <mathias.ettinger@viveris.fr> Tue, 9 Mar 2021 15:00:00 +0200
Source: opensand-deploy
Priority: optional
Maintainer: OpenSAND Maintainers <admin@opensand.org>
Build-Depends: debhelper (>= 7),
autotools-dev, automake, libtool, pkg-config,
libopensand-conf (>= 5.2.0),
libopensand-gse-encap-plugin (>= 5.2.0),
libopensand-rle-encap-plugin (>= 5.2.0),
opensand-core (>= 5.2.0)
Standards-Version: 3.8.3
Section: misc
Package: opensand-deploy
Architecture: any
Section: misc
Depends: libopensand-conf (= ${binary:Version})
Provides:
Conflicts:
Replaces:
Description: The configuration files generator for the OpenSAND emulation testbed
OpenSAND is an emulation testbed aiming to represent in a cost effective way a
satellite telecommunication system for research and engineering activities.
Upstream Author(s): TAS (Thales Alenia Space)
www.thalesaleniaspace.com
CNES (Centre National d'Etudes Spatiales)
www.cnes.fr
Copyright:
Copyright © 2021 TAS
Copyright © 2021 CNES
License:
Most parts:
OpenSAND is free software : you can redistribute it and/or modify it under the
terms of the GNU General Public License as published by the Free Software
Foundation, either version 3 of the License, or (at your option) any later
version.
This program is distributed in the hope that it will be useful, but WITHOUT
ANY WARRANTY, without even the implied warranty of MERCHANTABILITY or FITNESS
FOR A PARTICULAR PURPOSE. See the GNU General Public License for more
details.
You should have received a copy of the GNU General Public License along with
this program. If not, see http://www.gnu.org/licenses/.
On Debian systems, the complete text of the GNU General
Public License can be found in '/usr/share/common-licenses/GPL-3'.
Dama libraries:
OpenSAND is free software : you can redistribute it and/or modify it under
the terms of the GNU Lesser General Public License as published by the Free
Software Foundation, either version 3 of the License, or (at your option)
any later version.
This program is distributed in the hope that it will be useful, but WITHOUT
ANY WARRANTY, without even the implied warranty of MERCHANTABILITY or
FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License
for more details.
You should have received a copy of the GNU Lesser General Public License
along with this program. If not, see http://www.gnu.org/licenses/.
On Debian systems, the complete text of the GNU Lesser General
Public License can be found in '/usr/share/common-licenses/LGPL-3'.
#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
#
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.
#
# Modified to make a template file for a multi-binary package with separated
# build-arch and build-indep targets by Bill Allombert 2001
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
# This has to be exported to make some magic below work.
export DH_OPTIONS
# To avoid rebuilding everything when creating package
# Disable for releases !
#override_dh_auto_clean:
override_dh_install:
dh_install
install -m 0644 src/backend/backend.py $(CURDIR)/debian/opensand-deploy/var/opensand/opensand-conf/backend.py
install -m 0644 src/backend/opensand-conf.service $(CURDIR)/debian/opensand-deploy/etc/systemd/system/opensand-conf.service
install -d $(CURDIR)/debian/opensand-deploy/var/opensand/www/
cd src/frontend
yarn build
install -D -m 0644 build/* -t $(CURDIR)/debian/opensand-deploy/var/opensand/opensand-conf/static
override_dh_pysupport:
%:
dh $@
opensand-collector (6.0.0) xenial; urgency=low
* Release 6.0.0
-- mettinger <mathias.ettinger@viveris.fr> Tue, 9 Mar 2021 15:00:00 +0200
opensand-meta (5.2.0) xenial; urgency=low
* Release 5.2.0
......
opensand-collector (6.0.0) xenial; urgency=low
* Release 6.0.0
-- mettinger <mathias.ettinger@viveris.fr> Tue, 9 Mar 2021 15:00:00 +0200
opensand-network (5.2.0) xenial; urgency=low
* Release 5.2.0
......
opensand-collector (6.0.0) xenial; urgency=low
* Release 6.0.0
-- mettinger <mathias.ettinger@viveris.fr> Tue, 9 Mar 2021 15:00:00 +0200
opensand-output (5.2.0) xenial; urgency=low
* Release 5.2.0
......
opensand-collector (6.0.0) xenial; urgency=low
* Release 6.0.0
-- mettinger <mathias.ettinger@viveris.fr> Tue, 9 Mar 2021 15:00:00 +0200
opensand-gse-encap-plugin (5.2.0) xenial; urgency=low
* Release 5.2.0
......
opensand-collector (6.0.0) xenial; urgency=low
* Release 6.0.0
-- mettinger <mathias.ettinger@viveris.fr> Tue, 9 Mar 2021 15:00:00 +0200
opensand-rle-encap-plugin (5.2.0) xenial; urgency=low
* Release 5.2.0
......
opensand-collector (6.0.0) xenial; urgency=low
* Release 6.0.0
-- mettinger <mathias.ettinger@viveris.fr> Tue, 9 Mar 2021 15:00:00 +0200
opensand-rt (5.2.0) xenial; urgency=low
* Release 5.2.0
......
#!/bin/bash
# Process this file with autoconf to produce a configure script.
AC_INIT(opensand-gse-encap-plugin, 5.2.0, [http://opensand.org])
AC_INIT(opensand-gse-encap-plugin, 6.0.0, [http://opensand.org])
AC_CONFIG_SRCDIR([src])
AM_CONFIG_HEADER([config.h])
AM_INIT_AUTOMAKE
......@@ -39,7 +39,7 @@ LIBS="$OPENSAND_GSE_LIBS $LIBS"
AC_SUBST(AM_CPPFLAGS, "$OPENSAND_GSE_CFLAGS $AM_CPPFLAGS")
# check for opensand-plugin library
PKG_CHECK_MODULES([OPENSAND_PLUG], [opensand_plugin = 5.2.0])
PKG_CHECK_MODULES([OPENSAND_PLUG], [opensand_plugin = 6.0.0])
LIBS="$OPENSAND_PLUG_LIBS $LIBS"
AC_SUBST(AM_CPPFLAGS, "$OPENSAND_PLUG_CFLAGS $AM_CPPFLAGS")
......
#!/bin/bash
# Process this file with autoconf to produce a configure script.
AC_INIT(opensand-rle-encap-plugin, 5.2.0, [http://opensand.org])
AC_INIT(opensand-rle-encap-plugin, 6.0.0, [http://opensand.org])
AC_CONFIG_SRCDIR([src])
AM_CONFIG_HEADER([config.h])
AM_INIT_AUTOMAKE
......@@ -39,7 +39,7 @@ LIBS="$OPENSAND_RLE_LIBS $LIBS"
AC_SUBST(AM_CPPFLAGS, "$OPENSAND_RLE_CFLAGS $AM_CPPFLAGS")
# check for opensand-plugin library
PKG_CHECK_MODULES([OPENSAND_PLUG], [opensand_plugin = 5.2.0])
PKG_CHECK_MODULES([OPENSAND_PLUG], [opensand_plugin = 6.0.0])
LIBS="$OPENSAND_PLUG_LIBS $LIBS"
AC_SUBST(AM_CPPFLAGS, "$OPENSAND_PLUG_CFLAGS $AM_CPPFLAGS")
......
#!/bin/bash
# Process this file with autoconf to produce a configure script.
AC_INIT(opensand-rt, 5.2.0, [http://opensand.org])
AC_INIT(opensand-rt, 6.0.0, [http://opensand.org])
AC_CONFIG_SRCDIR([src])
AM_CONFIG_HEADER([config.h])
AM_INIT_AUTOMAKE
......@@ -39,7 +39,7 @@ PKG_PROG_PKG_CONFIG
CXXFLAGS="$CXXFLAGS -std=c++11"
# check for opensand-output library
PKG_CHECK_MODULES([OPENSAND_OUTPUT], [opensand_output = 5.2.0])
PKG_CHECK_MODULES([OPENSAND_OUTPUT], [opensand_output = 6.0.0])
LIBS="$OPENSAND_OUTPUT_LIBS $LIBS"
AC_SUBST(AM_CPPFLAGS, "$OPENSAND_OUTPUT_CFLAGS $AM_CPPFLAGS")
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment